use strict;
my $str = '<!-- Reply to message -->
<string name="mail_author_wrote">%1$s wrote…</string>
<string name="mail_hint_recipient">Recipient</string>
<string name="mail_hint_subject">Subject</string>
<string name="mail_hint_body">Body</string>
<string name="mail_send_to">"Send a message to %1$s"</string>
<string name="mail_send">Send a message</string>
<string name="mail_notification_msg">New message from</string>
<string name="mail_reply_to">Reply to %1$s</string>
<string name="mail_notification_author">from</string>
<string name="mail_theirs">View their message</string>';
my $regex = qr/string name="(.*)">[^%1\n]*</p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}