import Foundation
let pattern = #"<div class="x-grid-cell-inner " style="text-align: left; ;">([^<]*)<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<tbody><tr class="x-grid-header-row"><th class="x-grid-col-resizer-gridcolumn-1577" style="width: 1264px; height: 0px;"></th></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Brigitte</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Ferhat</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Hans</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Kevin</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">John</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Nathaniel</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Flavia</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">AJ</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Marilyn</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Raymond</div></td></tr></tbody>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)