use strict;
my $str = '<tbody><tr class="x-grid-header-row"><th class="x-grid-col-resizer-gridcolumn-1577" style="width: 1264px; height: 0px;"></th></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Brigitte</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Ferhat</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Hans</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Kevin</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">John</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Nathaniel</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Flavia</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">AJ</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Marilyn</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Raymond</div></td></tr></tbody>';
my $regex = qr/<div class="x-grid-cell-inner " style="text-align: left; ;">([^<]*)<\/div>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}