# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">([^<]*)<\/div>"
test_str = "<tbody><tr class=\"x-grid-header-row\"><th class=\"x-grid-col-resizer-gridcolumn-1577\" style=\"width: 1264px; height: 0px;\"></th></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Brigitte</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Ferhat</div></td></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Hans</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Kevin</div></td></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">John</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Nathaniel</div></td></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Flavia</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">AJ</div></td></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Marilyn</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Raymond</div></td></tr></tbody>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.