// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<div class="x-grid-cell-inner " style="text-align: left; ;">([^<]*)<\/div>"#).unwrap();
let string = "<tbody><tr class=\"x-grid-header-row\"><th class=\"x-grid-col-resizer-gridcolumn-1577\" style=\"width: 1264px; height: 0px;\"></th></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Brigitte</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Ferhat</div></td></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Hans</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Kevin</div></td></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">John</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Nathaniel</div></td></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Flavia</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">AJ</div></td></tr><tr class=\"x-grid-row x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Marilyn</div></td></tr><tr class=\"x-grid-row x-grid-row-alt x-grid-row-selected\"><td class=\" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first\"><div class=\"x-grid-cell-inner \" style=\"text-align: left; ;\">Raymond</div></td></tr></tbody>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}