package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div class="x-grid-cell-inner " style="text-align: left; ;">([^<]*)<\/div>`)
var str = `<tbody><tr class="x-grid-header-row"><th class="x-grid-col-resizer-gridcolumn-1577" style="width: 1264px; height: 0px;"></th></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Brigitte</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Ferhat</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Hans</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Kevin</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">John</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Nathaniel</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Flavia</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">AJ</div></td></tr><tr class="x-grid-row x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Marilyn</div></td></tr><tr class="x-grid-row x-grid-row-alt x-grid-row-selected"><td class=" x-grid-cell x-grid-cell-gridcolumn-1577 x-grid-cell-first"><div class="x-grid-cell-inner " style="text-align: left; ;">Raymond</div></td></tr></tbody>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}