// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(#(?:[A-z0-9]{3}){1,2})$").unwrap();
let string = "WHITE:
#FFFFFF
BLACK:
#000000
NOT THIS:
#12#111
Short hand grey:
#ccc
Invalid:
#efef
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}