import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#(?:[A-z0-9]{3}){1,2})$";
final String string = "WHITE:\n"
+ "#FFFFFF\n"
+ "BLACK:\n"
+ "#000000\n"
+ "NOT THIS:\n"
+ "#12#111\n"
+ "Short hand grey:\n"
+ "#ccc\n"
+ "Invalid:\n"
+ "#efef\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}