package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(#(?:[A-z0-9]{3}){1,2})$`)
var str = `WHITE:
#FFFFFF
BLACK:
#000000
NOT THIS:
#12#111
Short hand grey:
#ccc
Invalid:
#efef
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}