using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(#(?:[A-z0-9]{3}){1,2})$";
string input = @"WHITE:
#FFFFFF
BLACK:
#000000
NOT THIS:
#12#111
Short hand grey:
#ccc
Invalid:
#efef
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}