re = /^(#(?:[A-z0-9]{3}){1,2})$/m
str = 'WHITE:
#FFFFFF
BLACK:
#000000
NOT THIS:
#12#111
Short hand grey:
#ccc
Invalid:
#efef
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end