import Foundation
let pattern = #"^\s*([0-9]*\.?[0-9]*)\s+\d{1,2}[\W_]\s+([0-9A-F]+[x]?)\s+(?:Rx|Tx)\s+(?:d)\s([0-8])\s?((?:[0-9A-F]{2}[ ]?){0,8})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" 476.068710 3 A1 Rx d 1 01 23 54"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)