const regex = /^\s*([0-9]*\.?[0-9]*)\s+\d{1,2}[\W_]\s+([0-9A-F]+[x]?)\s+(?:Rx|Tx)\s+(?:d)\s([0-8])\s?((?:[0-9A-F]{2}[ ]?){0,8})$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*([0-9]*\\.?[0-9]*)\\s+\\d{1,2}[\\W_]\\s+([0-9A-F]+[x]?)\\s+(?:Rx|Tx)\\s+(?:d)\\s([0-8])\\s?((?:[0-9A-F]{2}[ ]?){0,8})$', 'g')
const str = ` 476.068710 3 A1 Rx d 1 01 23 54`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}