package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*([0-9]*\.?[0-9]*)\s+\d{1,2}[\W_]\s+([0-9A-F]+[x]?)\s+(?:Rx|Tx)\s+(?:d)\s([0-8])\s?((?:[0-9A-F]{2}[ ]?){0,8})$`)
var str = ` 476.068710 3 A1 Rx d 1 01 23 54`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}