#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\s*([0-9]*\.?[0-9]*)\s+\d{1,2}[\W_]\s+([0-9A-F]+[x]?)\s+(?:Rx|Tx)\s+(?:d)\s([0-8])\s?((?:[0-9A-F]{2}[ ]?){0,8})$"
Local $sString = " 476.068710 3 A1 Rx d 1 01 23 54"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")