# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*([0-9]*\.?[0-9]*)\s+\d{1,2}[\W_]\s+([0-9A-F]+[x]?)\s+(?:Rx|Tx)\s+(?:d)\s([0-8])\s?((?:[0-9A-F]{2}[ ]?){0,8})$"
test_str = " 476.068710 3 A1 Rx d 1 01 23 54"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.