$re = '/^(.*?)\s?(?|(?:dek[ae]t\s(.+)\sradius\s(\d+(?:\.\d+)?)\s?(k?m))|(?:dek[ae]t\s(.+)))/im';
$str = 'rumah dekat ugm
rumah dekat ugm radius 3 km
rumah dekat ugm radius 500m
rumah dekat sindu park radius 5 km
rumah dekat sindu park radius 1.5 km
rumah dekat De Mata Trick Eye Museum radius 12 km
apartemen dekat UII radius 2 km
dekat ugm radius 3 km';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);