const regex = /^(.*?)\s?(?|(?:dek[ae]t\s(.+)\sradius\s(\d+(?:\.\d+)?)\s?(k?m))|(?:dek[ae]t\s(.+)))/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\s?(?|(?:dek[ae]t\\s(.+)\\sradius\\s(\\d+(?:\\.\\d+)?)\\s?(k?m))|(?:dek[ae]t\\s(.+)))', 'img')
const str = `rumah dekat ugm
rumah dekat ugm radius 3 km
rumah dekat ugm radius 500m
rumah dekat sindu park radius 5 km
rumah dekat sindu park radius 1.5 km
rumah dekat De Mata Trick Eye Museum radius 12 km
apartemen dekat UII radius 2 km
dekat ugm radius 3 km`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}