using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\s?(?|(?:dek[ae]t\s(.+)\sradius\s(\d+(?:\.\d+)?)\s?(k?m))|(?:dek[ae]t\s(.+)))";
string input = @"rumah dekat ugm
rumah dekat ugm radius 3 km
rumah dekat ugm radius 500m
rumah dekat sindu park radius 5 km
rumah dekat sindu park radius 1.5 km
rumah dekat De Mata Trick Eye Museum radius 12 km
apartemen dekat UII radius 2 km
dekat ugm radius 3 km";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}