import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\s?(?|(?:dek[ae]t\\s(.+)\\sradius\\s(\\d+(?:\\.\\d+)?)\\s?(k?m))|(?:dek[ae]t\\s(.+)))";
final String string = "rumah dekat ugm\n"
+ "rumah dekat ugm radius 3 km\n"
+ "rumah dekat ugm radius 500m\n"
+ "rumah dekat sindu park radius 5 km\n"
+ "rumah dekat sindu park radius 1.5 km\n"
+ "rumah dekat De Mata Trick Eye Museum radius 12 km\n"
+ "apartemen dekat UII radius 2 km\n"
+ "dekat ugm radius 3 km";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}