use strict;
my $str = 'rumah dekat ugm
rumah dekat ugm radius 3 km
rumah dekat ugm radius 500m
rumah dekat sindu park radius 5 km
rumah dekat sindu park radius 1.5 km
rumah dekat De Mata Trick Eye Museum radius 12 km
apartemen dekat UII radius 2 km
dekat ugm radius 3 km';
my $regex = qr/^(.*?)\s?(?|(?:dek[ae]t\s(.+)\sradius\s(\d+(?:\.\d+)?)\s?(k?m))|(?:dek[ae]t\s(.+)))/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}