// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mU)^([0][\d]{1})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})|(\d{10})$").unwrap();
let string = "06.61.49.89.65
06 61 49 89 65
0661468965";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}