$re = '/^([0][\d]{1})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})|(\d{10})$/mU';
$str = '06.61.49.89.65
06 61 49 89 65
0661468965';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);