package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)^([0][\d]{1})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})|(\d{10})$`)
var str = `06.61.49.89.65
06 61 49 89 65
0661468965`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}