import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0][\\d]{1})(?:[.]|[ ]){1}([\\d]{2})(?:[.]|[ ]){1}([\\d]{2})(?:[.]|[ ]){1}([\\d]{2})(?:[.]|[ ]){1}([\\d]{2})|(\\d{10})$";
final String string = "06.61.49.89.65\n\n"
+ "06 61 49 89 65\n\n"
+ "0661468965";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}