#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)^([0][\d]{1})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})(?:[.]|[ ]){1}([\d]{2})|(\d{10})$"
Local $sString = "06.61.49.89.65" & @CRLF & _
"" & @CRLF & _
"06 61 49 89 65" & @CRLF & _
"" & @CRLF & _
"0661468965"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")