import Foundation
let pattern = #"<Trigger R="In a burst of feathers, a portal appears!" SD="DUCK PORTAL DUCK PORTAL DUCK PORTAL" ST="3" CR="F" C="Thalumbra Duck Portal" T="F" TN="" Ta="F">"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
\#FFFF00Jessip Daggerheart is attempting to sneak up on Aditu, but they haven't noticed... You should warn them!
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"warn ${Player}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)