#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<Trigger R="In a burst of feathers, a portal appears!" SD="DUCK PORTAL DUCK PORTAL DUCK PORTAL" ST="3" CR="F" C="Thalumbra Duck Portal" T="F" TN="" Ta="F">"
Local $sString = "\#FFFF00Jessip Daggerheart is attempting to sneak up on Aditu, but they haven't noticed... You should warn them!" & @CRLF & _
""
Local $sSubst = "warn ${Player}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)