$re = '/<Trigger R="In a burst of feathers, a portal appears!" SD="DUCK PORTAL DUCK PORTAL DUCK PORTAL" ST="3" CR="F" C="Thalumbra Duck Portal" T="F" TN="" Ta="F">/m';
$str = '\\#FFFF00Jessip Daggerheart is attempting to sneak up on Aditu, but they haven\'t noticed... You should warn them!
';
$subst = "warn ${Player}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;