import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Trigger R=\"In a burst of feathers, a portal appears!\" SD=\"DUCK PORTAL DUCK PORTAL DUCK PORTAL\" ST=\"3\" CR=\"F\" C=\"Thalumbra Duck Portal\" T=\"F\" TN=\"\" Ta=\"F\">";
final String string = "\\#FFFF00Jessip Daggerheart is attempting to sneak up on Aditu, but they haven't noticed... You should warn them!\n";
final String subst = "warn ${Player}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}