// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<day>\d\d).(?P<month>\d\d).(?P<year>\d{4})_").unwrap();
let string = "28.09.2017_SD1_to_orcam_bills_10indian";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}