const regex = new RegExp('(?P<day>\\d\\d).(?P<month>\\d\\d).(?P<year>\\d{4})_', 'g')
const str = `28.09.2017_SD1_to_orcam_bills_10indian`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}