using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<day>\d\d).(?P<month>\d\d).(?P<year>\d{4})_";
string input = @"28.09.2017_SD1_to_orcam_bills_10indian";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}