package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<day>\d\d).(?P<month>\d\d).(?P<year>\d{4})_`)
var str = `28.09.2017_SD1_to_orcam_bills_10indian`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}