$re = '/(?P<day>\d\d).(?P<month>\d\d).(?P<year>\d{4})_/';
$str = '28.09.2017_SD1_to_orcam_bills_10indian';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);