// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(((gain|loss|^d).*)isposal.*associates?)|").unwrap();
let string = "CFA
Disposal of an associates
Gain on disposal of an associate
Gain/loss on disposal of an associate
loss on disposal of an associate
CFI
Proceeds from disposal of an associate
abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}