re = /(((gain|loss|^d).*)isposal.*associates?)|/mi
str = 'CFA
Disposal of an associates
Gain on disposal of an associate
Gain/loss on disposal of an associate
loss on disposal of an associate
CFI
Proceeds from disposal of an associate
abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end