$re = '/(((gain|loss|^d).*)isposal.*associates?)|/mi';
$str = 'CFA
Disposal of an associates
Gain on disposal of an associate
Gain/loss on disposal of an associate
loss on disposal of an associate
CFI
Proceeds from disposal of an associate
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);