#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(((gain|loss|^d).*)isposal.*associates?)|"
Local $sString = "CFA" & @CRLF & _
"Disposal of an associates" & @CRLF & _
"Gain on disposal of an associate" & @CRLF & _
"Gain/loss on disposal of an associate" & @CRLF & _
"loss on disposal of an associate" & @CRLF & _
"CFI" & @CRLF & _
"Proceeds from disposal of an associate" & @CRLF & _
"abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")