import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((gain|loss|^d).*)isposal.*associates?)|";
final String string = "CFA\n"
+ "Disposal of an associates\n"
+ "Gain on disposal of an associate\n"
+ "Gain/loss on disposal of an associate\n"
+ "loss on disposal of an associate\n"
+ "CFI\n"
+ "Proceeds from disposal of an associate\n"
+ "abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}