re = /(\d{3})(\d{3})(\d{3})(\d{2})/
str = '12345678912'
subst = '$1.$2.$3-$4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result