const regex = /(\d{3})(\d{3})(\d{3})(\d{2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3})(\\d{3})(\\d{3})(\\d{2})', '')
const str = `12345678912`;
const subst = `$1.$2.$3-$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);