use strict;
my $str = '12345678912';
my $regex = qr/(\d{3})(\d{3})(\d{3})(\d{2})/p;
my $subst = '$1.$2.$3-$4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";