$re = '/(\d{3})(\d{3})(\d{3})(\d{2})/';
$str = '12345678912';
$subst = "$1.$2.$3-$4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;