using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{3})(\d{3})(\d{3})(\d{2})";
string substitution = @"$1.$2.$3-$4";
string input = @"12345678912";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}