import Foundation
let pattern = #"^(?:(?<LEADING_PUNCT>\+?[-. (]*)(?<COUNTRY_CODE>\d{1,3}))?(?<OPT_DELIM_1>[-. )(]*)(?<AREA_CODE>\d{1,3})?(?<OPT_DELIM_2>[-. )(]*)(?<PREFIX>\d{3})(?<OPT_DELIM_3>[-. )(]*)(?<SUFFIX>\d{4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
555 1212
555-1212
555.1212
5551212
936 555 1212
936-555-1212
936.555.1212
(936) 555-1212
9365551212
1 936 555 1212
1-936-555-1212
1.936.555.1212
1 (936) 555-1212
19365551212
+1 936 555 1212
+1-936-555-1212
+1.936.555.1212
+1 (936) 555 1212
+19365551212
23 4 555 1212
23-4-555-1212
23.4.555.1212
2345551212
+23 4 555 1212
+23-4-555-1212
+23.4.555.1212
+2345551212
+23 936 555 1212
+23-936-555-1212
+23.936.555.1212
+23 (936) 555 1212
+239365551212
+233 936 555 1212
+233-936-555-1212
+233.936.555.1212
+233 (936) 555 1212
+2339365551212
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)