// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?<LEADING_PUNCT>\+?[-. (]*)(?<COUNTRY_CODE>\d{1,3}))?(?<OPT_DELIM_1>[-. )(]*)(?<AREA_CODE>\d{1,3})?(?<OPT_DELIM_2>[-. )(]*)(?<PREFIX>\d{3})(?<OPT_DELIM_3>[-. )(]*)(?<SUFFIX>\d{4})$").unwrap();
let string = "555 1212
555-1212
555.1212
5551212
936 555 1212
936-555-1212
936.555.1212
(936) 555-1212
9365551212
1 936 555 1212
1-936-555-1212
1.936.555.1212
1 (936) 555-1212
19365551212
+1 936 555 1212
+1-936-555-1212
+1.936.555.1212
+1 (936) 555 1212
+19365551212
23 4 555 1212
23-4-555-1212
23.4.555.1212
2345551212
+23 4 555 1212
+23-4-555-1212
+23.4.555.1212
+2345551212
+23 936 555 1212
+23-936-555-1212
+23.936.555.1212
+23 (936) 555 1212
+239365551212
+233 936 555 1212
+233-936-555-1212
+233.936.555.1212
+233 (936) 555 1212
+2339365551212";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}