import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<LEADING_PUNCT>\\+?[-. (]*)(?<COUNTRY_CODE>\\d{1,3}))?(?<OPT_DELIM_1>[-. )(]*)(?<AREA_CODE>\\d{1,3})?(?<OPT_DELIM_2>[-. )(]*)(?<PREFIX>\\d{3})(?<OPT_DELIM_3>[-. )(]*)(?<SUFFIX>\\d{4})$";
final String string = "555 1212\n"
+ "555-1212\n"
+ "555.1212\n"
+ "5551212\n\n"
+ "936 555 1212\n"
+ "936-555-1212\n"
+ "936.555.1212\n"
+ "(936) 555-1212\n"
+ "9365551212\n\n"
+ "1 936 555 1212\n"
+ "1-936-555-1212\n"
+ "1.936.555.1212\n"
+ "1 (936) 555-1212\n"
+ "19365551212\n\n"
+ "+1 936 555 1212\n"
+ "+1-936-555-1212\n"
+ "+1.936.555.1212\n"
+ "+1 (936) 555 1212\n"
+ "+19365551212\n\n"
+ "23 4 555 1212\n"
+ "23-4-555-1212\n"
+ "23.4.555.1212\n"
+ "2345551212\n\n"
+ "+23 4 555 1212\n"
+ "+23-4-555-1212\n"
+ "+23.4.555.1212\n"
+ "+2345551212\n\n"
+ "+23 936 555 1212\n"
+ "+23-936-555-1212\n"
+ "+23.936.555.1212\n"
+ "+23 (936) 555 1212\n"
+ "+239365551212\n\n"
+ "+233 936 555 1212\n"
+ "+233-936-555-1212\n"
+ "+233.936.555.1212\n"
+ "+233 (936) 555 1212\n"
+ "+2339365551212";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}