#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?<LEADING_PUNCT>\+?[-. (]*)(?<COUNTRY_CODE>\d{1,3}))?(?<OPT_DELIM_1>[-. )(]*)(?<AREA_CODE>\d{1,3})?(?<OPT_DELIM_2>[-. )(]*)(?<PREFIX>\d{3})(?<OPT_DELIM_3>[-. )(]*)(?<SUFFIX>\d{4})$"
Local $sString = "555 1212" & @CRLF & _
"555-1212" & @CRLF & _
"555.1212" & @CRLF & _
"5551212" & @CRLF & _
"" & @CRLF & _
"936 555 1212" & @CRLF & _
"936-555-1212" & @CRLF & _
"936.555.1212" & @CRLF & _
"(936) 555-1212" & @CRLF & _
"9365551212" & @CRLF & _
"" & @CRLF & _
"1 936 555 1212" & @CRLF & _
"1-936-555-1212" & @CRLF & _
"1.936.555.1212" & @CRLF & _
"1 (936) 555-1212" & @CRLF & _
"19365551212" & @CRLF & _
"" & @CRLF & _
"+1 936 555 1212" & @CRLF & _
"+1-936-555-1212" & @CRLF & _
"+1.936.555.1212" & @CRLF & _
"+1 (936) 555 1212" & @CRLF & _
"+19365551212" & @CRLF & _
"" & @CRLF & _
"23 4 555 1212" & @CRLF & _
"23-4-555-1212" & @CRLF & _
"23.4.555.1212" & @CRLF & _
"2345551212" & @CRLF & _
"" & @CRLF & _
"+23 4 555 1212" & @CRLF & _
"+23-4-555-1212" & @CRLF & _
"+23.4.555.1212" & @CRLF & _
"+2345551212" & @CRLF & _
"" & @CRLF & _
"+23 936 555 1212" & @CRLF & _
"+23-936-555-1212" & @CRLF & _
"+23.936.555.1212" & @CRLF & _
"+23 (936) 555 1212" & @CRLF & _
"+239365551212" & @CRLF & _
"" & @CRLF & _
"+233 936 555 1212" & @CRLF & _
"+233-936-555-1212" & @CRLF & _
"+233.936.555.1212" & @CRLF & _
"+233 (936) 555 1212" & @CRLF & _
"+2339365551212"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")