using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?<LEADING_PUNCT>\+?[-. (]*)(?<COUNTRY_CODE>\d{1,3}))?(?<OPT_DELIM_1>[-. )(]*)(?<AREA_CODE>\d{1,3})?(?<OPT_DELIM_2>[-. )(]*)(?<PREFIX>\d{3})(?<OPT_DELIM_3>[-. )(]*)(?<SUFFIX>\d{4})$";
string input = @"555 1212
555-1212
555.1212
5551212
936 555 1212
936-555-1212
936.555.1212
(936) 555-1212
9365551212
1 936 555 1212
1-936-555-1212
1.936.555.1212
1 (936) 555-1212
19365551212
+1 936 555 1212
+1-936-555-1212
+1.936.555.1212
+1 (936) 555 1212
+19365551212
23 4 555 1212
23-4-555-1212
23.4.555.1212
2345551212
+23 4 555 1212
+23-4-555-1212
+23.4.555.1212
+2345551212
+23 936 555 1212
+23-936-555-1212
+23.936.555.1212
+23 (936) 555 1212
+239365551212
+233 936 555 1212
+233-936-555-1212
+233.936.555.1212
+233 (936) 555 1212
+2339365551212";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}